AABS Package

package for:

Assignment and Analysis of Broadband Spectra

This is a package for graphical analysis of broadband spectra with resolved rotational structure. The spectra can be pure rotational spectra, from cascaded multiplication, FASSST or chirped pulse FTMW techniques. The package can be (and has been) used to analyse also rotation-vibration or vibronic spectra from Fourier transform interferometers, or laser spectrometers. Even if true broadband spectra are not available the package allows concatenation of many shorter spectra into a single spectrum and efficient operation on such a segmented spectrum. The first published application of the AABS package and its initial description have been given in

Z.Kisiel, L.Pszczolkowski, I.R.Medvedev, M.Winnewisser, F.C.De Lucia, E.Herbst, J.Mol.Spectrosc. 233,231-243(2005)

and that paper can be used for citation. Since then the package has been used in many further studies, and a summary of some of the more advanced applications can be found in

Z.Kisiel, L.Pszczolkowski, B.J.Drouin, C.S.Brauer, S.Yu, J.C.Pearson, I.R.Medvedev, S.Fortman, C.Neese, J.Mol.Spectrosc. 270,134-144(2012)

In this documentation you will find

  • A general description of the package
  • Some snapshots of the package in operation
  • The recommended installation procedure
  • The recommended preparatory steps to running the package
  • The recommended way of launching the package
  • Description of typical operation
  • Description of the two main constituent programs: SVIEW_L and ASCP_L
Zbigniew Kisiel, version 30.V.2024

Institute of Physics, Polish Academy of Sciences,
http://info.ifpan.edu.pl/~kisiel/prospe.htm


AABS Package help 1

A general description of the AABS package:
At the core of the AABS package are two display programs:
  • SVIEW_L = viewer of the spectrum (annotated preview)
  • ASCP_L = viewer of predictions (annotated previews of the main and the LW screens)

which are integrated with several other programs. The package also comprises of the utility program AC , which allows generation of dataset distribution plots that allow rapid overview of large spectroscopic datasets.

ASCP_L is normally used as the active program, and the display of SVIEW_L is locked to it. Predictions of spectroscopic species of relevance to the current spectrum can be loaded into the program and displayed with various options for distinguishing between the various species. A special highlighting option by 'cloning' the current line allows highlighting of a transition sequence of interest. Frequency regions around successive predictions in this sequence can then easily be inspected in turn, and if there are suitable lines in the spectrum those can be measured. The frequency determined by SVIEW_L and quantum numbers from ASCP_L can be added to a specified datafile for the fitting program. When deviations from predictions are not too large then the analysis process involves only two keystrokes per line. Predictions and data for fitting can be in the standard of either SPFIT/SPCAT or ASFIT / ASROT packages.

Below is a snapshot of the AABS package after the frequency of a line in the spectrum closest to prediction for the transition has been measured by simply pressing the - key in ASCP_L. Pressing the F1 key instead would have added an entry for this line to the specified file for the fitting program (in this case v20v39.LIN file for SPFIT). Click on the diagram for an annotated version.

Click for an annotated version

An alternative mode of operation is to draw a Loomis-Wood type plot of strips of the experimental spectrum centred on successive highlighted lines. This display in its basic mode actually uses peakfinder results instead of the actual spectrum, which enables very fast operation. This mode is especially suitable for earlier stages of assignment. Measurements and addition of data to the fitting file can be made a similar way to that in the main display mode, requiring only two-three keystrokes per spectral line. Below is a snapshot of the LW mode displaying spectral segments centred on frequencies of successive Ka=1¬0, R-type ground state transitions in the FASSST rotational spectrum of diethyl ether (click on the image to see an annotated version):

Click for an annotated version

AABS snapshots
Some further snapshots of the AABS display on typical operation:
  • snapai - the summary of information on the data files loaded for the example above and obtained by pressing the I key in ASCP_L. Ten different prediction files, consisting of a mix of .ASR and .CAT files have been read and their transitions merged and sorted for plotting.
  • The primary help system is as contained in the present .CHM file, but it is also possible to display online help screens with Ctrl H. For the ASCP_L basic display mode these are: snapah1 - the main online help screen, snapah2 - the second help screen summarising the ASCP_L commands that are specific to linked operation with SVIEW_L, and snapah3 - the third help screen summarising the files that can be used by ASCP_L

The utility of the Loomis-Wood display mode is based on visually spotting patterns formed by related transitions. In order to facilitate this many extended display possibilities have been built into this mode. The LW strips can be drawn as a simple stick representation of the spectrum, as open and filled triangle approximations to the spectrum, and can also be from the actual spectrum. Several alternative colour schemes and output leading to PostScript/PDF diagrams are available.

  • snaplw - the preferred open triangle mode of the LW screen, which provides an optimum between clarity and speed of operation and has been adapted from the excellent Loomis-Wood program written in the Winnewisser group in Giessen. This plot is obtained on pressing the F5 key while in the normal display, after having marked a transition sequence in the standard mode, as in the snapshot snapaabs above. The spectral strips can be easily scrolled in four directions, a movable cursor is available to select desired lines, and indication of assigned lines can be toggled on and off.
  • snaplwst , snaplwft - stick type and filled triangle versions of the LW display, which are toggled through by pressing the p key. Useful for more broadband, and more close in work, respectively.
  • snaplws - Loomis-Wood type plot using strips of the actual spectra, obtained by pressing the [ key in the LW display mode.
  • scheme1 , scheme2 , scheme3 - some different combinations of display and colour schemes for the LW display, selectable with the C and p keys in the LW display mode.
  • snaplwt.pdf - result from output for the gle program, which is automatically generated for the Loomis-Wood display as above. Gle can then be used to compile the generated files into PostScript and PDF diagrams. Such diagram can also be generated in other display modes, as well as in portrait orientation.
  • snaplwh - the online help screen in the Loomis-Wood type plot obtained with Ctrl H.

The recommended installation procedure for the package:
  • Create a directory called C:\ROT on your computer and place in it the five files downloaded from the PROSPE website:
SVIEW_L.EXE
ASCP_L.EXE
AABS.CFG
ASCPEXCH.DLL
AABS_HELP.CHM
  • Place shortcuts to SVIEW_L and ASCP_L on the desktop. And this would be all !
  • Actually this is not all for the more recent versions of Windows in which you might get the message "Msvcr71.DLL cannot be found" when you try to launch either of the two programs. If that is the case you also need the file MSVCR71.DLL, which is best placed in the same directory as the programs, namely C:\ROT.
  • NOTE: the name C:\ROT for the directory containing the program files is mandatory and cannot be changed. The analysis projects themselves can, however, be in any directory of choice.
On first time use on a new system you might perhaps also want to adjust the graphics size of the AABS programs to the size that you are prepared to devote to them on the desktop. The program windows are not freely scalable but their size is adjustable and is declared in the file AABS.CFG , which may need to be reedited.

In addition, if you plan to use ASFIT / ASROT for fitting/prediction, as well as other programs from the PROSPE website, then it is recommended that these are also placed in the C:\ROT directory. For more convenient launching of these programs from the command line you can optionally add C:\ROT to your system path. One way of doing this (on XP) is to go through the dialogue:

Control Panel ® System ® Advanced ® Environment Variables ® PATH

and to append ;c:\rot to the value of that variable. Another way involves locating the file AUTOEXEC.NT, normally in C:\WINDOWS\SYSTEM32 and adding to it the line path=c:\rot if there was no previous such line in this file, and if there is one then append to it ;c:\rot.

You might want to download a complete sample project, and follow the associated mini-tutorial to check out some features of the package without the need for setting up a project from scratch.

The recommended preparatory steps to running the package (so as to take advantage of its main features):
  • Create a directory which is to contain all work associated with analysis of a given spectrum.
  • Copy your broadband spectrum to this directory - it is recommended that the spectrum be in the compact binary mode used by SVIEW_L. This can easily be generated since SVIEW_L can read a spectrum as a two column ASCII file of point frequencies and intensities (preferably, but not necessarily, equally spaced in frequency). Binary file is then generated with the M option.
  • Generate peakfinder output for this spectrum if Loomis-Wood type plots are to be used for assignment. This is to be done by using the automatic peakfinder of SVIEW_L, which is invoked by specifying a negative value for the 0 option.
  • Make sure you have either SPFIT/SPCAT or ASFIT / ASROT running on your computer, the relevant executables can also be placed in directory C:\ROT
  • It is highly recommended that you have a text editor that is able to sense that the contents of an opened file has changed and it can then refresh it. The standard Notepad editor is not able to do this but, for example, the PSPAD editor can. The ability to carry out columnar editing is also highly desirable.
  • Edit a suitable version of the SVIEW_L.INP file
  • Edit a suitable version of the MOLNAM.INP file, which declares the names of prediction files to be displayed by ASCP_L.
  • When working with a segmented spectrum it is, optionally, possible to use a file called LIST to specify the frequency segments for which there is data. This file can either be created using SLIST (if the component spectra are available) or by reediting this LIST example - only the frequency entries are of relevance.

The recommended way of launching the package:
  • From your favourite file manager drag and drop the spectral file onto the SVIEW_L icon on the desktop, then press ENTER
  • Drag and drop the MOLNAM.INP file onto the ASCP_L icon on the desktop. Press 2 ENTER for batch input, and then just ENTER as a data file name.
  • In the text editor open the data files associated with fitting the current spectroscopic species of interest as declared in SVIEW_L.INP. These might be either .LIN, .PAR, .FIT files for SPFIT, or .ASF, .RES files for ASFIT
  • Open a command prompt window, with the current directory set to the work directory for the current problem, This window is to be used for running the fitting and prediction programs used with the package.
  • The two viewing programs should have opened as two adjacent strips. Almost all operations are carried out from within ASCP_L, which controls the display of SVIEW_L as necessary. There are, however, two tuning tasks for dealing with the spectrum that it might be necessary to perform in SVIEW_L. One is setting the optimum width of the fitting window for determining line frequencies - expand a line profile with A/S keys and optimise using the O and 0 options. Another task is Y-axis scaling of the spectrum - use W/Z and 2/3 keys.

Typical operation:
  • Click (or use ALT TAB) to make ASCP_L the active window - this should be the lower of the two strips. Note that there is minimal mousing around - almost all commands are issued from the keyboard, which is a much faster device and allows increased efficiency. It pays to study and learn the main keys for controlling the programs and summary charts ASCP_L_KEYS and SVIEW_L_KEYS have been prepared to print and keep handy. Note that the navigation commands for the two programs are identical. If your help file viewer does not allow reading PDF files then use these bitmaps: ASCP_L_KEYS_1 , ASCP_L_KEYS_2 and SVIEW_L_KEYS.
  • Move to the stick corresponding to a line from a line sequence of interest and highlight this sequence with t. It might actually be easier to just move to any line predicted for this spectroscopic species, use T to preselect a range of lines, and then find the desired type of line with left/right arrows. Subsequently t will highlight the sequence precisely.
  • Move along the lines in the highlighted sequence with left/right arrows and make measurements as necessary, mainly with F1 or F2. If a line in the spectrum is significantly off the cursor position you can move closer to it with 2/3 keys of ASCP_L and then measure.
  • You might want to check on the progress of accumulation of measurements in the fitting data file by moving to the text editor window. The data file is not locked by the AABS programs so that lines can be rearranged/tidied, the file saved, and further data will be appended to the modified file.
  • Go to the command line window and carry out fitting and prediction in your favoured way. It is recommended to browse through the results file from the fit prior to embarking on predictions. If working with SPFIT you might find it useful to reformat the .FIT file with program PIFORM , which improves readability and allows annotations on the data file. The fitting/prediction is not automated on purpose. It is hoped that in this way the user can spot any problems earlier and will take suitable corrective action, before it is too late.
  • Once new predictions are ready press ESC in ASCP_L, which updates predictions, as well as markers of lines already measured. To switch to a new spectroscopic species place the name of the new file for the fitting program in SVIEW_L.INP and update both SVIEW_L and ASCP_L by pressing ESC.
  • In more difficult cases launch the Loomis-Wood display by setting the cursor on a highlighted line and pressing F5. Use the help screen of this display for information. The steps above can be carried out as many times as necessary - it is not necessary to close the two display programs at any stage.


Sview_L Help

=

Spectral VIEWer for Linked operation

SVIEW_L is a viewer of spectra, which can work either in stand-alone mode or as part of the AABS package. In the second case the program operates in linked mode under control of ASCP_L. Several copies of SVIEW_L can also be launched in order to compare different spectra covering the same frequency region.

SVIEW_L should accept spectra of unlimited length and is dynamically dimensioned so that it doesn't hog memory for small spectra. Stand-alone operation is usually a prerequisite to linked operation since the spectra are often first reedited with SVIEW_L for use in further analysis.

Default input is from compact binary files in the IFPAN standard. It is also possible to read from two column [frequency,intensity] ASCII files. In such case equidistant point spacing is useful but not mandatory, and automatic conversion to an average point spacing will be made. Data read in ASCII format can then be saved in the binary format. The standard display is as shown below (click on the image for an annotated version):

Click for an annotated version

A white background version is also possible:

B/W colour version

From here you can jump to the various subsections of SVIEW_L documentation:

  • Principal features of SVIEW_L
  • Installation
  • Launching
  • Keyboard operation

Principal features of SVIEW_L:

SVIEW_L has been designed to preview/modify/measure/output broadband spectra recorded with rotational resolution by any spectrometer capable of producing such spectra. The principal features are:

  • input from and output to the compact IFPAN MMW binary storage mode,
  • input from (and output to) two column ASCII, in which case the first line in the file is assumed to contain a descriptive comment, and the remaining lines should contain [frequency,intensity] pairs. The two values in each line should be separated by at least a space or a comma, and it is best if frequency increments are equal. If they are not then the program will interpolate its own equally spaced set of points by cubic splines,
  • flexible scrolling/zooming along the frequency and the intensity coordinates. Special internal modes for efficient viewing of spectra at conditions when those are considerably zoomed-in or zoomed-out relative to their data point spacing,
  • measurement of peak frequency, intensity and linewidth,
  • automatic peakfinder,
  • background subtraction using least squares smoothing in a procedure that allows minimisation of spurious effects close to very strong lines,
  • normal smoothing and differentiation,
  • blanking of known lines,
  • miscellaneous spectrum modifications including spectrum inversion, chopping, frequency and Y-axis shifts etc.,
  • appending/concatenation of many spectra into a single spectrum,
  • output for the gle program which, in turn, can produce publication quality PostScript/EPS/PDF/JPG diagrams,
  • easy reconfiguration to adapt to the preferred size/style of the graphics window, including full-height and half-height display options.

When used as part of the AABS package SVIEW_L is normally the passive program and its display is locked to that of ASCP_L. Measurements are also actioned from ASCP_L. It may, however, still be necessary to jump to SVIEW_L temporarily to:

  • adjust the width of the line measurement window,
  • adjust vertical zoom and vertical position of the viewing window onto the spectrum,
  • refresh information on the current fitting data file.
Installation of SVIEW_L:

SVIEW_L is usually installed as part of the AABS package, as described in separate installation instructions for the package . Even if the program is only to be used in the stand-alone you still need to copy all of the files mentioned there, with the exception of ASCP_L.EXE.

Having copied the necessary file you can optionally place a shortcut to SVIEW_L on the desktop, and the size of the graphics window can be tweaked by editing the file AABS.CFG .

Launching SVIEW_L:

SVIEW_L can be launched in many different ways, as allowed by the Windows environment:

  • The spectral file is located with any file manager and then dragged and dropped onto the SVIEW_L icon on the desktop. It is then only necessary to press ENTER in answer to the first question posed by the program.
  • A variation on the above is to place the SVIEW_L icon on the taskbar of the file manager that you are using (if it has such a feature) and then drag the file icon onto that.
  • The SVIEW_L icon on the desktop can be clicked, the ENTER key pressed in answer to the first question and the spectrum located using the standard Select File box that appears. Note that several typical file types have been predefined and can be selected in the bottom window of the box to reduce the number of displayed files.
  • Command prompt window is opened and the program is launched by simply typing SVIEW_L<ENTER>. The rest of the procedure is as above. Note that most Windows variants will remember the location of the most recently read spectrum.
  • If you assign certain predefined extensions to your spectral files (such as .SPE) then it is possible to associate this extension with SVIEW_L, by using either the standard mechanism provided by Windows, or one of many accessory programs. File manager will then identify such associated file with the SVIEW_L icon, and double clicking the file is sufficient to launch the program for input of this file.

Keyboard operation:

SVIEW_L is characterised by fast operation, ensured in part by the design decision for complete control from the keyboard. This may be relatively unpleasant for first-time users so that, to alleviate the pain, a summary of the active keys is given here .
A printable version of this chart is also available on the program website at http://info.ifpan.edu.pl/~kisiel/aabs/sview_l_keys.pdf (this is not a clickable link but is designed to be pasted into your browser). Perusal of this chart is a recommended starting point for finding out about the available program features.This chart can be printed and kept at hand.

The crucial navigation keys for zooming and shifting the viewing window over the spectrum are arranged on the left-hand side of the keyboard in a modified cross arrangement, and are identified on the chart as pairs of a given colour. It is intended that these keys are operated with fingers of the left hand, whereas the right hand operates the cursor keys K,L.

The keys are collected into groups based on related type of action:

  1. Navigation : A,S 2,3 Q,E W,Z K,L F Ctrl F , Home End
  2. Display modification : - 4 8,* C ^ Ctrl P U
  3. Spectrum modification : B Ctrl B N Ctrl N M & R
  4. Measurement : O Ctrl O 0 9 = +
  5. Input/Output : m G Enter ESC
  6. Information : I P H Ctrl H
  7. Linked operation with ASCP_L : Esc F7 F8

More detailed description of the individual keys is given below.

Navigation :
A S | Shift viewing window over the spectrum (left/right)
2 3 Shift viewing window over the spectrum (up/down)
Q E Zoom frequency axis of the viewing window (out/in)
W Z Zoom vertical axis of the viewing window (increase/decrease)
K L Move cursor over the spectrum (left/right)
NOTE:

All of the above are fast slow for upper/lower case. Thus if Caps Lock is off then pressing Shift together with a navigation key increases the magnitude of the appropriate operation.
F Manually specify lower and upper frequency limits Flow,Fhigh for the viewing window. Two special modes are possible:

-ve Flow, ENTER for Fhigh: centre the display on the absolute value of Flow without changing the frequency range

ENTER for Flow, -ve Fhigh: change frequency range to magnitude of Fhigh without changing the centre frequency
Ctrl F View complete frequency range of the spectrum, while keeping the current Y-axis amplification (which can then be autoscaled with 4 if desired)
, Toggle cursor position between successive quarter positions on the horizontal axis of the viewing window. First press centers the cursor.
Home Move to beginning of spectrum (see below).
End | Move to the end of spectrum (not operative in linked mode unless F7 is used to suspend linked operation)
Display modification :
- | Invert the Y-axis of the spectrum.
4 Autoscale Y-axis of the current viewport (this scaling will be preserved on horizontal scrolling through the spectrum)
8 * * assumes that the spectrum is in MHz and toggles its frequency to cm-1 and back.
8 assumes that the spectrum is in cm-1 and toggles its frequency to MHz and back.
C Toggle the colour scheme between the default blue and B/W. The latter is mainly designed for pasting into presentations. Note that much higher quality configurable B/W output is possible with G.
^ Toggle window height between narrow (default) and full size.
Ctrl P Toggle between normal (default) and histogram (as in radioastronomy) plotting modes.

The default plotting mode has three automatically selected submodes:
  1. plot with interpolation between the input data points,
  2. point by point plot of the input data,
  3. compression plot for fast plots of long data runs.
The histogram mode only plots the actual data points from the input spectrum.

U | Toggle through three possible linewidths for plotting the spectrum. The default (and fastest) is the single pixel linewidth. The two thicker linewidths are mainly designed for improved clarity of spectral traces in screen copies of SVIEW_L windows at larger pixel dimensions.
Spectrum modification :
B Subtract baseline variation.

The baseline is defined by least-squares smoothing the spectrum with a window that is at least an order of magnitude broader than the linewidths. The smoothing window is defined in terms of the number of data points in the spectrum. Baseline subtraction in SVIEW_L works best for second derivative lineshapes and it is possible to use it in three different ways:

METHOD I: Straightforward subtraction by using a positive value for the width of the smoothing window (n>3 and odd)

METHOD II: Subtraction by using a negative value for the width of the smoothing window (n<-3 and odd): this is the method of choice for routine use since it attenuates the effect of strong lines on the derived baseline with the aid of selectable cutoff limits.

METHOD III: A hybrid method for more effective subtraction of relatively sharp baseline features when these appear in the presence of strong lines. The steps are:
  1. Subtract the broader baseline fluctuations with method II, save the spectrum and exit SVIEW_L.
  2. Relaunch SVIEW_L on the saved spectrum and generate a peaklist of the strongest lines (0 -n option) giving it the name ECHO.ASC.
  3. Blank the strongest lines (ctrl B option). Blanking by zeroing is usually more robust than interpolation. Also check baseline level and adjust with 9 if necessary.
  4. Finally subtract the baseline with method II but with a suitably narrower interval than in step 1.
Ctrl B Blank the spectrum at positions of known lines. Prerequisites are:
  1. generation of an ECHO.ASC file with lines to be blanked by using the batch input mode of ASCP_L
  2. suitable setting of the width to be used for blanking a line
N Standard least-squares smoothing of the spectrum.
Ctrl N Least-squares first derivative of the spectrum (with smoothing).
M Miscellaneous modification options on the loaded spectrum: chopping, zeroing, axis shifts, expansion. Pressing this key displays the menu of the possible options.
& Appending of additional spectra to the current spectrum. The appended spectra do not have to directly continue from the current spectrum, and they can also be in a different point spacing in frequency. The appended sections will be created by interpolation onto the frequency grid defined by the first spectrum.

Appending/concatenation of spectra only works in the binary SVIEW_L format of the same byte length.

HINT: if the first spectrum is at an inconvenient frequency spacing you can enforce the desired spacing by means of a dummy first spectrum. This needs to contain only a few points declared in ASCII with a text editor and converted to the binary SVIEW_L format. Once the final spectrum is built the dummy spectrum can be deleted from it with the M option.

R | Restore original spectrum (as first read in) if processing operations are to be discarded. Invaluable for testing various background subtraction/smoothing options. NOTE: This option will not work if the either the append & or the spectral modification M mode has been used.
Measurement :
O | Measure the line nearest the cursor. The measured parameters are frequency, intensity and linewidth. If the Y-coordinate of the point under the cursor is above the current baseline level then the program will attempt to locate the nearest maximum. If the cursor point is below the baseline then the nearest minimum will be located. The level of the baseline can be changed with 9. Precise position of the extremum is defined by fitting a parabola, and various construction lines are drawn to indicate the measurement.
Ctrl O Same as the above, except that peak height will be evaluated in the units in which the spectrum was recorded (check with I).
0 Specification of the number of points to be used for the width of the line measurement interval. The default method is the AUTO mode, which uses the number of points corresponding to the FWHH of the line.

The lines can also be measured by assuming a fixed measurement width. In the AUTO mode this fixed width is used for an initial estimate of the number of points in FWHH.

Negative value of the measurement width launches automatic peakfinder, which can act either on the current viewing window or on the complete spectrum. The peakfinder runs only in the fixed width mode.
9 Use coordinates of the point under the cursor as the measured line frequency and as the baseline level. Useful for measuring distorted lines 'by eye' and for fine tuning the baseline level when the automatically derived value is not suitable.
= Evaluate straightforward average and difference frequencies of the last two measured lines.
+ | Evaluate intensity weighted average and difference frequencies of the last two measured lines.
Input/Output :
m | Output the current spectrum, either in ASCII or in the IFPAN binary format. Use the 4-byte binary output format for spectra with very high signal to noise ratio, such as deeply averaged chirped pulse spectra or InSb detected MMW spectra.
G Automatically generate control and data files for the gle program, which can then be compiled into Postscript/EPS/PDF/JPG diagrams.

The associated dialogue allows the spectrum to be split into one/two/three strips per page and also to be spread over multiple pages if necessary.
ESC Reread the spectrum if the time of its last modification has changed. If linked operation with ASCP_L has been established then pressing this key will also action rereading the contents of the SVIEW_L.INP file (see below).
ENTER | Exit to the spectrum input dialogue, which allows reading in a different spectrum.
Information :
I | Show information on the spectrum.
P Show actual data points.
H Display this help file, namely AABS_HELP.CHM, which has to reside in directory c:\rot.
Ctrl H | Display the old-style online help screens coded within the program.
Linked operation with ASCP_L :
ESC | Reread the SVIEW_L.INP file (and also the spectrum if it has been modified). The SVIEW_L.INP file has to reside in the same directory as the spectrum, and it defines the name of the data file to which the measured data is to be appended, as well as some other operational parameters. This file can be modified with any editor. NOTE that a switch of the active data file requires pressing the ESC key in both SVIEW_L and ASCP_L.
F7 Three state toggle of linked operation between SVIEW_L and other AABS programs:
  1. Completely linked mode indicated by the filled red square in the top right corner of the area containing the spectrum. This is the default state of the program and allows full external control by ASCP_L (but only when the program finds a valid SVIEW_L.INP file).
  2. Partially linked mode indicated by the empty red square in the top right corner of the area containing the spectrum. In this mode SVIEW_L will only act on frequency but not on other control information produced by ASCP_L. This mode is useful when several instances of SVIEW_L have been launched but only one (set to mode 1) is enabled to write output to the data file, while the other instances are set to mode 2.
  3. Unlinked mode with no red symbol in the top right corner of the area containing the spectrum. This mode blocks receipt of any control information from ASCP_L or other instances of SVIEW_L but still allows the current instance to control the frequency axis of those instances of SVIEW_L that are in mode 1 or 2. This mode is also assigned automatically in the case of missing or invalid SVIEW_L.INP file.
F8 On/Off toggle of an additional pointer marking the frequency difference from a highlighted line of magnitude defined by the current cursor position in SVIEW_L and the frequency of current highlighted line in ASCP_L.

To be set directly after placing the ASCP_L cursor on a suitable highlighted line. This feature is useful when frequency difference between prediction and a candidate line sequence is appreciable, but is expected to be relatively invariant along the sequence.

 | The following keys are also active but are rarely used, since their operation has been superseded by similar actions issued directly from ASCP_L:
F1 | Measure the line nearest the cursor and add it to the dataset as a standard transition to be fitted. The quantum numbers will be those most recently selected by the cursor in ASCP_L
F2 Measure nearest line and add it to the dataset as part of a blend.
F3 Measure nearest line and add it to the dataset as an excluded line.


Ascp_L Help

=

Viewer of Spectral Predictions for Linked operation

ASCP_L is a viewer of predictions, displayed in any combination of stick or simulated spectrum form. Predictions can be merged from many different data sets, so that any mixture of transitions calculated for different molecules, different isotopic species, different vibrational/electronic states can be displayed simultaneously. The program can work either in stand-alone mode or as part of the AABS package. In the second case the program operates in linked mode and controls viewing and measurements on a spectrum displayed in SVIEW_L.

ASCP_L accepts an unlimited number of transitions, which can come from (currently) up to 350 different data sets. Data sets can be read in any order, can be scaled relative to each other and the lines can be filtered with frequency and intensity cutoffs. Transitions can be distinguished in various different ways using colour, linestyle, and highlighting attributes. The information displayed for each transition includes six quantum numbers per energy level, lower state energy, frequency, intensity and dataset name (click on the image or here to see an annotated version):

Click for an annotated version

ASCP_L also has a second operational mode, which can be used once some spectral information is available. This is the Loomis-Wood mode in which strips of the spectrum are aligned on calculated frequencies for successive transitions in some sequences highlighted in the main mode above. The LW mode allows rapid graphical assignment of broadband spectra and is an important feature of the AABS package. Further information on this mode is in the description of the AABS package. You can also jump directly to an annotated screen of the LW mode.

The various subsections of the ASCP_L documentation are as follows:

  • Principal features of ASCP_L
  • Installation
  • Launching
  • Colour and linestyles
  • Keyboard operation (main mode)
  • Keyboard operation (Loomis-Wood mode)
Principal features of ASCP_L:

ASCP_L has been designed to preview any combination of spectroscopic predictions and its principal features are:

  • Display of an unlimited number of lines from up to 50 different data sets
  • The display can be either a stick diagram or simulated spectrum or sticks + simulated spectrum. Spectral simulation can be for zeroth, first or second derivative of Gaussian or Lorentzian lineshape function - example , and also inclusive of Doppler doubling for jet spectra.
  • Input of data in .ASR format of ASROT , which can come from ASROT itself, or from SPCAT, as converted from .OUT files with the program PISORT
  • Input of .CAT files of SPCAT
  • Input of [frequency,intensity] format
  • Input of .FRE format of automatic peakfinder in SVIEW_L
  • Batch input mode for hands-off input and merging of many data sets, including a refresh mode to take account of results of recalculation
  • Filtering of input data sets according to frequency and intensity, and possibility of outputting the filtered data
  • Different data sets can be displayed in selectable colour , linestyle and adjustable relative intensity. Two colour coding schemes for lines are available. Colour is usually assigned according to the data set , but it can also be according to transition type : various shades of red for aP, aR- and aQ-types, greens for b-types, blues for c-types, and yellow for unrecognized transition type.
  • Complete horizontal and vertical scrollability, and Y-axis reversal
  • Movable cursor displays parameters of lines currently under the cursor (all six SPFIT/SPCAT quantum numbers per energy level, transition frequency, intensity, lower level energy)
  • Multiple highlighting options of subsets of transitions on the basis of many different definitions of commonality: the same value of a given common quantum number, the same data set, or the same transition type
  • Several selectable overall colour schemes for the display
  • Intensities of overlapped lines can either be summed or not. Highlighted lines can be brought to the foreground to facilitate spotting sparse transitions in crowded spectra.
  • Various information screens including summary of input data, scrollable listing screen, and help screens.
  • Separate Loomis-Wood display mode for graphical assignment of spectra. In this mode strips are plotted from either the simplified representation of the spectrum based on peakfinder output or from the spectrum itself.
  • Output from all display modes for the gle program which, in turn, can produce publication quality PostScript/EPS/PDF/JPG diagrams,
  • The ranges and names of recorded spectra can be indicated on the plot either from information contained in the file LIST generated by SLIST or from information provided by SVIEW_L
  • Easy reconfiguration to adapt to the preferred size/style of the graphics window, including full-height and half-height display options.

When used as part of the AABS package ASCP_L is normally the active program and controls the display of the spectrum read into SVIEW_L. In this mode:

  • All actions performed in ASCP_L on the frequency axis are automatically followed by SVIEW_L, so that predictions and spectrum are scrolled/zoomed synchronously.
  • Measurement of line frequencies on the spectrum displayed in SVIEW_L can be actioned from ASCP_L. The measured frequency can be saved to the fitting data file, together with quantum numbers of the transition selected by the cursor in either the main or the Loomis-Wood display mode of ASCP_L.
Installation of ASCP_L:

ASCP_L is usually installed as part of the AABS package, as described in separate installation instructions for the package . Even if the program is only to be used in the stand-alone you still need to copy all of the files mentioned there, with the exception of SVIEW_L.EXE.

Having copied the necessary file you can optionally place a shortcut to ASCP_L on the desktop, and the size of the graphics window can be tweaked by editing the file AABS.CFG .

Launching ASCP_L:

ASCP_L can be launched in many different ways, as allowed by the Windows environment:

  • The legal input file for ASCP_L (either a file with predictions or a batch input file) is located with any file manager and then dragged and dropped onto the ASCP_L icon on the desktop. It is then only necessary to select the input mode, and then to press ENTER in answer to the filename question posed by the program.
  • A variation on the above is to place the ASCP_L icon on the taskbar of the file manager that you are using (if it has such a feature) and then drag the file icon onto that.
  • The ASCP_L icon on the desktop can be clicked, the input mode selected, and then the ENTER key pressed in answer to the filename question. The appropriate input file can then be located using the standard Select File box that appears. Note that several typical file types have been predefined and can be selected in the bottom window of the box to reduce the number of displayed files.
  • Command prompt window is opened and the program is launched by simply typing ASCP_L<ENTER>. The rest of the procedure is as above. Note that most Windows variants will remember the location of the most recently read spectrum.
  • If you assign certain predefined extensions to your input files containing predictions or batch input commands (such as .ASR, .CAT or .INP) then it is possible to associate these extensions with ASCP_L, by using either the standard mechanism provided by Windows, or one of many accessory programs. File manager will then identify such associated file with the ASCP_L icon, and double clicking the file is sufficient to launch the program for input of this file.

Keyboard operation:

ASCP_L , in similarity to SVIEW_L, is characterised by fast operation, ensured in part by the design decision for complete control from the keyboard. This may be relatively unpleasant for first-time users so that, for faster familiarisation and reference, a summary of the active keys is given in Main screen keys and LW screen keys.
A printable version of these two charts is also available on the program website at http://info.ifpan.edu.pl/~kisiel/aabs/ascp_l_keys.pdf (this is not a clickable link but is designed to be pasted into your browser). Perusal of these charts is a recommended starting point for finding out about the available program features.

The crucial navigation keys for zooming and shifting the viewing window over the spectrum are arranged on the left-hand side of the keyboard in a modified cross arrangement, and are identified on the chart as pairs of a given colour. It is intended that these keys are operated with fingers of the left hand, whereas the right hand operates the cursor keys K,L. In the Loomis-Wood mode the right-hand usually operates the four arrow navigation keys: ←,→,↓,↑.

The keys are collected into groups based on related type of action, and are somewhat different for the main display mode (below), and for the Loomis-Wood mode ( separate table ). Although launching SVIEW_L is not necessary for the Loomis-Wood mode, it is still necessary to provide the SVIEW_L.INP file in order to define the names of the peakfinder file and of the fitting data file.

Keys for the main display mode:
  1. Navigation : A,S 2,3 Q,E W,Z K,L F , Home End ↓,↑ ←,→ Ctrl←,Ctrl→ PgUp,PgDown CtrlPgUp,CtrlPgDown
  2. Display modification : & 8,* P u U Y C M ^ V Ctrl V F5
  3. Highlighting : r R CtrlR d D CtrlD 5 % T t ←,→
  4. Input/Output : G CtrlG Esc Enter
  5. Information : I O H Ctrl H
  6. Linked operation with SVIEW_L : F1 F2 F3 2,3 4 - = F8 F9 F10 0
Navigation :
A S | Shift the viewing window along the frequency axis (left/right)
2 3 These keys have a dual functionality:

1/ When a simulated spectrum has been generated with the M option then the two keys will action an (up/down) shift of the simulated spectrum. They have no effect on the sticks.

2/ When ASCP_L is linked with SVIEW_L then the two keys will fine tune the position of the frequency cursor in SVIEW_L. But if a simulated contour has been generated then it is still possible to shift it (up/down) by using suboption 6 of the M option.

Q E Zoom the frequency axis of the viewing window (out/in)
W Z Zoom the vertical axis of the viewing window (increase/decrease)
K L Move the cursor along the frequency axis (left/right). Positioning the cursor over a line displays the parameters of the line (see the annotated screen).
NOTE:

All of the above are fast slow for upper/lower case. Thus if Caps Lock is off then pressing Shift together with a navigation key increases the magnitude of the appropriate operation.
F Manually specify lower and upper frequency limits Flow,Fhigh for the viewing window. Two special modes are possible:
  • -ve Flow, followed by ENTER for Fhigh: centre the display on the absolute value of Flow without changing the frequency range
  • ENTER for Flow, followed by -ve Fhigh: change frequency range to the magnitude of Fhigh without changing the centre frequency
, Toggle cursor position between successive quarter positions on the horizontal axis of the viewing window. First press centers the cursor.
Home Move to the beginning of the frequency axis as defined by the data.
End Move to the end of the frequency axis defined by the data.
↓ ↑ Toggle through information on components of a blend when there are overlapped transitions at the cursor frequency.
← → Toggle the cursor (and the display) through successive highlighted lines.
Ctrl←
 Ctrl→ 		Move the cursor (and the display) to the next lower/next upper segment in a segmented spectrum if such has been defined by means of the LIST file.
PgUp
 PgDown 		Toggle the cursor (and the display) through successive frequency flags, providing that such flags have been set with V or have been input from a previously saved LIST_flags file (this file is read on program startup and on the Esc refresh operation).
Ctrl PgUp Ctrl PgDown | Toggle the cursor (and the display) through successive data points in the fitting file.

Display modification :
& | Invert the Y-axis of the display.
8 * Convert the frequency scale between units of MHz and cm-1.
P Toggle stick colours between colours assigned on the basis of:
  1. Transition type: this is the default mode and is indicated by transCOLOURS on the bottom of the display. The colours are chosen on the basis of the dipole moment component involved in the transition and the selection rule on J, as listed in this chart.
  2. The dataset: indicated by dtsetCOLOURS. These colours are assigned by the user on input by means of the line code number (see chart). This is best carried out in batch input mode by using the MOLNAM.INP file.

  3. Vibrational state: indicated by vstatCOLOURS. This is possible only in the case of an asymmetric rotor and is decided on the basis of the value of the vibrational index (the fourth quantum number). The colours are hardcoded within the program.
u
Toggle the use of different linestyles associated with different line colours (see chart). Current setting is indicated on the bottom row of the display as noLSTYLES or useLSTYLES.
U Toggle the use of thick (default) or thin line highlighting.
Y Add/do not add intensities of degenerate transitions. Current setting is indicated on the bottom row of the display as notADDED or ADDED (see the annotated screen).
C Toggle between the different predefined colour schemes for the display. The choice depends on user preference or the task at hand. For example, the first scheme toggled after the default blue scheme offers a greater colour contrast between highlighted lines and most of the predefined line colours.
M Enter the dialogue defining whether to draw sticks, a simulated spectrum or both.

Parameters of the simulated spectrum are also specified here: Gaussian or Lorentzian lineshapes in zeroth, first or second derivative form can be used. It is also possible to simulate a doubled line profile, such as that from Doppler doubling.

It is recommended that the number simulated contour points is adjusted to avoid loss of lineshape quality.
^ Toggle window height between narrow (default) and full size.
V Set a frequency flag at the current cursor frequency or, if there already is a flag at this frequency, then the flag will be removed. It is possible to move the display to centre on successive flags with the PgUp, PgDown keys.
Ctrl V Save the currently set frequency flags to file LIST_flags. This file, if present in the project directory, is automatically read on program startup and on the Esc refresh operation.
F5 | Launch the Loomis-Wood mode. In order to do this it is first necessary to highlight a transition sequence. The LW mode also requires a peakfinder list file for the spectrum, previously generated with SVIEW_L.
Highlighting :
r | Highlight all lines from the same data set that contains the line selected by the cursor.
R Highlight all lines from all data sets.
Ctrl R Highlight all lines in the current data set with the same selection rule on all quantum numbers as for the selected line (case insensitive).
d Highlight all lines in the current data set with the same value of the selected lower state quantum number. Successive presses of this key toggle through all quantum numbers.
D Highlight all lines in all data sets with the same value of the selected lower state quantum number. Successive presses toggle through all quantum numbers.
Ctrl D Highlight all lines in the current data set with the same value of the selected upper state quantum number. Successive presses toggle through all quantum numbers (case insensitive).

This option also changes the display of the energy value in the second information line at the top: the default is Elower in cm-1, while with active upper state highlighting this is Eupper in K and is printed in red.
5 Highlight all lines in the current data set with the same lower energy level.
% Highlight all lines in the current data set with the same upper energy level.
T Highlight all transitions in the current data set with a specified value of a given quantum number, and a specified selection rule on another quantum number.

Example: T 2,0 followed by 1,1 selects all transitions with Ka=0 and Delta J=+1, providing that asymmetric top quantisation is in action (quantum numbers 1,2,3.. are J,Ka,Kc,...)
t Highlight all transitions with the same value of a selected quantum number as in the currently selected transition and with the same selection rule as in the current transition. When there are more than three quantum numbers in use then it is also possible to fix a value of an additional quantum number at that for the current transition.

Example: assuming the cursor is on the 10,1,10 ← 9,1,9 asymmetric rotor transition then:

  • t 2 will select both aR0,1 transition sequences with Ka=1
  • t -2 will only select the Ka=1, aR0,1 transition sequence with Ka+Kc=J+1
Ctrl T List selected additional highlighting operations:

1/ Filter hyperfine components of transitions such that only the largest F' component remains highlighted. This operation requires prior use of any of the other highlighting operations and will retain highlighting only for the strongest component of each multiplet.
The main purpose of this option is to allow meaningful Loomis-Wood operation. First use requires specification of:
  • The position of F among the six possible quantum numbers (typically 4 for an asymmetric rotor with a single quadrupolar nucleus and no vibrational quanta, and 5 for one with vibrational quanta)
  • The total nuclear spin rounded up to the nearest integer, consistent with the convention used by SPFIT/SPCAT. Examples: 1 for single 14N, 2 for single Cl or Br, 3 for two Cl, 5 for three Cl nuclei.

2/ Highlight all lines belonging to a given R-branch band, and based on the current cursor selected line This is currently limited to n=2,type-II+ bands, which are characteristic of high-J spectra of planar, asymmetric rotor molecules.

This feature is ultimately intended to deal with all bands discussed in Table 9 of Kisiel+Pszczolkowski, J.Mol.Spectrosc. 178,125(1996). For the time being note that the common type-I- band can be selected using T 1,J followed by 1,1 (where J is the value of the J quantum number for the band).
← → | Move the cursor (and the display) to the next lower/next higher highlighted line.
Input/Output :
G | Automatically generate control and data files of the current display for the gle program, which can then be compiled into Postscript/EPS/PDF/JPG diagrams. The gle script is a readable ASCII file, which can be reedited for much further customisation of the diagram. Some possibilities are suggested in the 'customisation options' block at the top of this file. The G option has dual operation. The default mode produces a diagram of just the ASCP_L display. It is also possible to obtain a diagram of the dual pane AABS display once the spectrum has been read into ASCP_L with the [ option of the Loomis-Wood screen. In that case the intensity scaling and vertical position of the spectrum are as determined in the LW screen.
Ctrl G Generate a data file containing information on all currently highlighted lines. The Ctrl G option is primarily designed to extract information on the highlighted lines, as written into the .dat file. A control file for the gle package is also generated to produce a plot of (J +1) scaled frequencies of these lines against J.
NOTE: operatio of this option requires a linked SVIEW_L since it participates in file output.
Esc Reread all of the data input files specified in the batch input file. If manual input was used then the refresh will only be possible for a single file. The contents of the SVIEW_L.INP file will also be reread.
Enter | Exit ASCP_L.
Information :
I | Show information on the loaded data files.
O Display a scrollable linelist of merged and sorted lines with the entrance point defined by the cursor frequency.
H Display this help file, namely AABS_HELP.CHM, which has to reside in the directory c:\rot.
Ctrl H | Display a succession of three online help screens coded within the program and summarising the commands and file types used by ASCP_L.
Linked operation with SVIEW_L :
F1 | Measure the nearest line to the cursor in the spectrum displayed in SVIEW_L and add it to the dataset as a standard transition to be fitted. The quantum numbers will be those most recently selected by the cursor in ASCP_L
F2 Measure the nearest line and add it to the dataset as part of a blend.
F3 Measure the nearest line and add it to the dataset as an excluded line.
2 3 Shift the cursor in SVIEW_L left/right without moving the cursor in ASCP_L. This allows measurement of line frequencies that are appreciably different from prediction. This functionality takes precedence over the use of the 2,3 keys to Y-shift a simulated spectrum (as described in the navigation keys above)
4 Autoscale Y-axis of the current SVIEW_L viewport (this scaling will be preserved on successive horizontal scrolling operations)
- Measure a line in SVIEW_L without saving.
= Determine the average frequency of the last two measurements made with the - option and save the result to the fitting file. Useful, for example, for measuring the centre frequency of a Doppler or internal rotation doublet.

F8 F9 F10

Successive use of the keys F8, F9, F10 allows relative intensity measurements on lines A and B. The feature is mainly intended to determine the vibrational energy difference between states containing the compared lines. Note that the derived energy difference ΔE (B – A) is based on information NOT already built into the calculated absorption coefficients of the two lines.

Different rotational energies, dipole moments, nuclear spin statistical weights and spectroscopic degeneracies (if summed) are already accounted for in absorption coefficients, and non-zero ΔE will only result if predictions for states containing lines A and B are vibrationless. The data files for the two states are best loaded in batch mode, and their intensity scaling coefficients will not affect the ΔE evaluation. If two polyads are compared then ΔE will reflect the difference between the zero energies of the polyads.
F8 Measure the first line of a pair of lines for relative intensity measurement (line A). This option can also be used for various comparisons between the spectrum and the predictions. The parameters listed in each line written to the data file are:

Measured from the spectrum in SVIEW_L:

  1. frequency= fmeas
  2. estimated uncertainty in measured frequency
  3. intensity = Imeas
  4. linewidth (FWHH)

Taken from the cursor selected line in ASCP_L:

  5. predicted frequency= fcalc
  6. calculated intensity = αmax
  7. intensity multiplier in the ASCP_L display
  8. state identifier for relative intensity (A or B)
  9. quantum numbers
  10. fmeas– fcalc
  11. Imeas/αmax

F9 Measure the second line of a pair of lines for relative intensity measurement (line B).
F10 Evaluate and save to the fitting file the energy difference from the relative intensity measurement on the two lines previously measured with options F8 and F9. The evaluation uses the two relations:

Irel = (Imeas/αmax)B / (Imeas/αmax)A
ΔE (B – A) = – kT ln (Irel)

so that it is assumed that the differences between the considered transitions (such as different line strengths, rotational energies, dipole moments, statistical weights, line broadening parameters) are incorporated in the respective αmax values. Some specific notes:
  1. The evaluation temperature can be changed by using the T option in SVIEW_L
  2. Measurements made with the F8 option can be coadded in that the calculated absorption coefficient values are summed. The same is the case for the F9 option. In this way relative intensities of complex blends can be evaluated. Pressing the F10 key resets the coaddition.
  3. The evaluation does not use the intensity multiplier specified for intensity scaling of datasets in the ASCP_L display but the Irel value can be compared against, or used to determine, this multiplier.

The F10 key also writes a single line summary of each relative intensity measurement to the file relint_measurements.csv, which is a comma delimited text file. This file can be imported into a spreadsheet program (Excel or LibreOffice calc) for further processing such as statistics.
0 Save the predicted parameters of a line (quantum numbers, frequency, intensity) to the fitting data file as a clearly identified excluded line. This mechanism is convenient, for example, if a small subset of additional lines is to be measured individually. SVIEW_L does not provide any information to this option, but a linked instance of this program still needs to be open (on any spectrum) since it is SVIEW_L that carries out the saving operation.

Note that the 0 key allows the use of the conveniently positioned key from the numeric keypad.

Keys for the Loomis-Wood display mode:
  1. Navigation : A,S 2,3 Q,E W,Z K,L , ←,→ ↓,↑ PgUp,PgDown
  2. Display modification : F P p [ { C B j J +,- O
  3. Measurement : F1 F2 F3
  4. Input/Output : G T
  5. Information/Exit : H Ctrl H F5 Enter

More detailed description of the individual keys is given below.

LW Navigation :
A S | Shift the viewing window along the frequency axis (left/right)
2 3 If the LW strips display the actual spectrum then shift the spectrum up/down.
Q E Zoom the frequency axis of the viewing window (out/in)
W Z Zoom the vertical axis of the viewing window (increase/decrease)
K L Move the cursor horizontally along a strip. Two automatically selected modes are used:
  1. when the strip contains peakfinder entries then the cursor jumps between frequencies of successive peakfinder lines,
  2. when the strip has no peakfinder entries then the cursor moves by frequency increments as in the main mode. In this case F1,F2,F3 operations are blocked.
NOTE:

All of the above are fast/slow for upper/lower case. Thus if Caps Lock is off then pressing Shift together with a navigation key increases the magnitude of the appropriate operation.
, Move the cursor to either the zero frequency, and if that is not possible to the centre of the current strip.
← → Move the cursor horizontally (identical in function to the the K,L keys). The reason for duplication is increased efficiency since the other set of arrows is used for the vertical motion (see below)
↓ ↑ Move the cursor up/down between the strips.
PgUp PgDown | Move all strips up/down as set in suboption 4 of the O key (default value is one)
LW Display modification :
F | Toggle the legend display on the right hand side of each strip between the first three quantum numbers, the last three quantum numbers, and the centre frequency.
P Toggle through the available plotting modes for peakfinder lines: sticks, open triangles, and filled triangles.
p Show/do not show measured lines that are already in the fitting data set.
[ Toggle between the peakfinder list and the actual spectrum for plotting the strips. Using the spectrum is currently the preferred display mode. First use of the option loads the spectrum, which is then retained. On full AABS operation it is recommended that SVIEW_L is launched first, in which case the same spectrum will be loaded automatically into ASCP_L. Otherwise the spectrum needs to be located via the Select File box.
{ Delete the spectrum from ASCP_L memory and the buffer created to hold it. This is normally used as a preparatory step to switching to another spectrum, but it can also be used if there is a shortage of RAM and it is necessary to release memory space.
C Toggle between the different predefined colour schemes for the display.
B Go to predefined frequency span equal to 1000 times the nominal error, and centre the display on the calculated frequencies for the defining transitions.
j Sort strips according to the value of the predefined quantum number. Useful, for example, for sorting the lines of a given Q-branch in order of J.
J Toggle through the quantum numbers to define the quantum number to be used for sorting.
+ - Increase/decrease the number of strips. It is usually much quicker to do this with strips displaying peakfinder lines, and only then switch to strips displaying the spectrum.
O Entry to some additional plot modification options. For complex spectra the first two options might help to clarify the display.

1 - Set a relative intensity cutoff for display (default value 0.05 = 5%).

2 - Filter out peakfinder lines accounted for by preceding datasets.

3 - Change the frequency/wavenumber span of the strips, useful if some exact value is desired.

-3 - Change the nominal frequency measurement error saved with each measurement to the fitting file. The error is normally read in from the SVIEW_L.INP file, while this option overrides that value (and also automatically transmits the new value for use by SVIEW_L). Useful when switching between MMW and FIR analyses without exiting ASCP_L.

4 - Change the increment for PageUp/PageDown operation (i.e. the number of by which the display is scrolled up or down).

5 - Access to the COMB mode, which is sometimes useful for spotting sequences of lines nearly equidistant in frequency. It is best to use this mode with LW display of the actual spectrum. Once the mode is activated then WYSIWYG control is possible of the frequency spacing (K,L keys) and of the cubic, DJ-type correction (N,M keys).
LW Measurement :
F1 | 'Measure' the line selected by the cursor by appending an appropriate entry to the fitting data file. The saved information consists of the peakfinder frequency, the quantum numbers of the current strip, and the nominal error from SVIEW_L.INP. This operation is only possible when the cursor moves between peakfinder entries (as described for the K and L keys).
F2 'Measure' the line identified by the cursor by appending it to the fitting data file as part of a blend (i.e. with an intensity value to be used for weighting). Only possible when the cursor moves between peakfinder entries.
F3 | 'Measure' the line identified by the cursor by appending it to the fitting data file as an excluded line. Only possible when the cursor moves between peakfinder entries.
LW Input/Output :
G | Automatically generate control and data files of the current display for the gle program, which can then be compiled into Postscript/EPS/PDF/JPG diagrams. NOTE that the number of gle data files will be the same as the number of strips in the display.

T | Produce frequency difference output for the gle program. This will be successful only if the LW plot is for transitions other than state 1, which is assumed to be the reference (usually the ground) state. The plot will be of frequency differences between lines with the same quantum numbers in the highlighted state and the reference state. Optional scaling by J+1 for P- and R-types or Ka for Q-types is possible.
LW Information/Exit :
H | Display this help file, namely AABS_HELP.CHM, which has to reside in the directory c:\rot.
Ctrl H Display the on-line help screen coded within the program and containing a summary of the commands available in the Loomis-Wood mode.
F5 Exit the LW mode. This is the same key as is used to enter the mode so that it is possible to change between the modes rapidly.
Enter | Also exit the LW mode.


ASCP_L Colours and Linestyles

Colours and linestyles in ASCP_L
Colours and linestyles are specified by means of the linestyle index defined either during the data input dialogue or in the batch input file.

Values 1-10 of the linestyle index correspond to predefined colours/linestyles as below. Values greater than 10 (but not greater than 50) allow declaration of any custom colour using its RGB specification. This is only possible in the batch file and the value of the linestyle index is in such case to be followed by the hexadecimal RGB colour, for example:

11,#FF0000

for red. The linestyle (if required) is determined automatically from the decimal version of the RGB index.
Predefined dataset colours:

Generated, from left to right, for linestyle parameter from 1 to 10.

The use of either the dataset colours or of the transition type colours below is toggled with the P key.
Transition type colours:

The first three from the left are for aP, aQ, aR, then bP, bQ, bR, then cP, cQ, cR, and finally for an unidentified rotational transition type.
Predefined linestyles:

Generated, from left to right, for linestyle parameter from 1 to 10.

The use of linestyles is toggled on/off with the U key and linestyles can be used with either one of the two colour schemes. All green lines in this example are in the colour for bR transitions.


Fitting+predictions

Using AABS with various fitting/prediction programs:
The AABS package is designed to work without any modifications with SPFIT/SPCAT and with ASFIT / ASROT . The file standards of these two packages have also been used to allow work with ERHAM and with XIAM, as well as with the V6 version of BELGI. This is achieved by means of relatively simple converter programs, which are available on the PROSPE website. Any other spectral fitting package can, in principle, be interfaced with AABS in this way.

 No provision is provided for running the fitting/prediction programs from within AABS but, once this is done externally, the results can be updated by using the ESC key in both ASCP_L and SVIEW_L. Pressing this key actions, first of all, rereading of SVIEW_L.INP. This makes it possible to switch to a different fitting file, but it is necessary to perform the ESC action in both display programs. In ASCP_L pressing ESC will also reread predictions and the fitting file. Note that if more than one set of predictions has been read into ASCP_L then those will be reread only if their input has been made in batch mode by means of the MOLNAM.INP file. The contents of this file is reread on ESC, so that reediting of MOLNAM.INP can be used to change which predictions are to be read in and/or to change their display parameters, such as colour and relative intensity.

SPFIT/SPCAT:
  • Fitting file: this is identified by the extension .LIN in the name declared in the SVIEW_L.INP file. If the declared file is not found then it will be created by whichever of the two AABS display programs is opened first (in versions 29th July 2010 or later). Furthermore, the quantisation of lines written to the .LIN files is now dependent on the quantisation in the predictions (this is a change from previous versions where the contents of the .LIN file determined the quantisation). The current scheme appears to be more natural but it introduces a new risk of mixing lines with different quantisations in one .LIN file.
  • Predictions: These have to be in the format of .CAT files and are identified as such on the basis of the file contents. There is, therefore, no limitation on file names, although the use of the extension .CAT is still recommended. Note that the .PAR, .VAR, .INT files necessary for the problem have to be created externally.

ASFIT / ASROT :
  • Fitting file: this is identified by the extension .ASF in the name declared in the SVIEW_L.INP file. The declared file has to be created externally, either by running ASFIT or, more frequently, by reediting a previous .ASF file.
  • Predictions: These have to be in the format of .ASR files for ASROT and are identified as such on the basis of their contents. There is, therefore, no limitation on file names, although the use of the extension .ASR is still recommended. The quantisation in these files was originally limited to three asymmetric top quantum numbers, but there is a subvariant of this format (introduced by the PISORT program) that allows the use of six quantum numbers per energy level.

ERHAM (see these separate instructions):
The 2013 version of ERHAM, namely erhamv16g-r3 allowed a significant simplification of the integration with AABS. That version produced predictive output in the .CAT standard of SPCAT and defined quantisation by means of eight quantum numbers, using the 4th and the 8th to store the ERHAM labels IS1,IS2. The simplest integration with AABS is as follows:
  • Fitting file: this is to be in the .LIN standard with quantum numbers as in the .CAT output of ERHAM. Measurements are written to this file, which is then converted with program LINERH into an input file for ERHAM. This input file can be edited manually as desired, and the ERHAM output can be converted to an updated .LIN file with program ERHRES.
  • Predictions: The .CAT type predictions file generated by ERHAM is used directly for display by ASCP_L.

XIAM:

Automatic conversion between measurements made with AABS and XIAM input is not available, but the frequency block of the input file can be readily set up from other formats by using a text editor with columnwise editing features. There are, however, some postprocessing programs available:

  • Fitting: The XIAM output file can be reformatted into a (hopefully) more readable format with XIARES. This program is to be used with the modified XIAM5 executable available in the XIAM extras section of the website. Note that the XIAM5,XIARES combination deals with unorthodox ealuation of a weighted deviation of fit in the original XIAM.
  • Predictions: The predictions generated by XIAM can be converted with XA into extended .ASR type files that are read and displayed by ASCP_L.


AABS.INP configuration file

The AABS.CFG configuration file:
This file is used by both ASCP_L and SVIEW_L to set the same basic window size and appearance. Note that not all fonts may be available on a given Windows machine, and same named font may have different metrics on different versions of Windows. Thus you may sometimes have to experiment a bit by setting various multiples of 30 for the vertical pixel size and of 80 for the horizontal pixel size.

The rationale for this solution has, of course, been the relative simplicity to program, while keeping the appearance of the program windows unchanged. Satisfactory operation has been achieved on all Windows platforms from Win98 onwards, on desktops, laptops, and on screens up to 24".

The presence of AABS.CFG is actually optional, but if it is not found in the C:\ROT directory, then the programs default to the use of windows fitting on an 800x600 pixel screen.

The file begins with the first line containing the ! character as the first character. This defines that the line is a comment line and the number of such lines is unlimited. Only the batch of lines directly following the comments is read.

!--------------------------------------------------------------------------
!  CONFIGURATION FILE FOR AABS used by both ASCP_L and SVIEW_L:
!  (all header lines beginning with ! are ignored)
!
!  Text handling is hardcoded in the programs to 30rows x 80columns in the
!  double height version, so choose pixel ranges, which are integer multiples
!  of these numbers.
!
!  The default operation of both ASCP_l and SVIEW_l is in half-height
!  window, which corresponds to 17 rows.
!  The Loomis-Wood mode opens a window corresponding to 42 text rows.
!
!  The font can be any fixed-spaced (monotype) font known to the system but
!  note that bitmapped fonts are only available for a limited range of fixed
!  sizes and pixel sizes commensurate with capabilities of large displays
!  may not be available.
!
!  Common fonts that will work are:
!
!                    Truetype:    Courier New
!                                 Lucida Sans Typewriter Regular
!                                 Lucida Console
!                                 Bitstream Vera Sans Mono
!
!                    Bitmapped:   Fixedsys
!                                 System
!                                 Terminal
!
!  If the font cannot be set then the system will default to Courier New font
!  at default resolution, which is usually rather smaller than that required.
!
!  As many extended font attributes as desired can be specified, some are
!  additive, others mutually exclusive:
!
!  1 _NORMAL      5 _FIXED_PITCH      7 _FF_ROMAN       12 _ANSI_CHARSET
!  2 _UNDERLINE   6 _VARIABLE_PITCH   8 _FF_SWISS       13 _DEFAULT_CHARSET
!  3 _BOLD                            9 _FF_MODERN      14 _SYMBOL_CHARSET
!  4 _ITALIC                         10 _FF_SCRIPT      15 _OEM_CHARSET
!                                    11 _FF_DECORATIVE
!
!  QWIN defaults are _NORMAL, _FIXED_PITCH, _FF_MODERN, _ANSI_CHARSET
!
!--------------------------------------------------------------------------
!  Current configuration is to follow immediately below
!--------------------------------------------------------------------------
!
!  For general use on screens from 17 to 22" at >=1280x1024 resolution
!
!----------------------------------____------------------------------------
 Width of ASCP  window in pixels:  1120
Height of ASCP  window in pixels:   660                    <--- for full ht
                    Name of font:  Courier New
         Extended font attribute:     1
         Extended font attribute:     5
         Extended font attribute:     9
         Extended font attribute:    12
!----------------------------------____------------------------------------

//////////////////////////////////////////////////////////////////////////
Identified working configurations (not exhaustive):
//////////////////////////////////////////////////////////////////////////

Pixel size Width,Height is for net window size. Height refers to full height
window, but AABS programs open and are mostly used at half-height.
Height1 is for net LW window height and is given by 42*Height/30

Actual window size depends on the system version: add 30-40 pixels for total
window height, and 6 pixels for total window width .

Courier New, normal (first extended font attribute = 1):

Width:     640 800 800 880 960 960 1120 1120 1200 1280 1280 1360 1440 1520
Height:    510 540 600 540 540 600  540  660  660  630  660  630  630  810
Height1 -> 714 756 840 756 756 840  756  924  924  882  924  882  882 1134

Courier New, bold (first extended font attribute = 3):

Width:     800   800   880
Height:    510   540   510
Height1 -> 714   756   714

Courier New, italic (first extended font attribute = 4):

Width:     720
Height:    540
Height1 -> 756

Bitstream Vera Sans Mono, normal:

Width:     880  800
Height:    510  570
Height1 -> 714  798

Lucida Console, normal:

Width:     800  800
Height:    480  540
Height1 -> 672  756

//////////////////////////////////////////////////////////////////////////
Sample configurations (to use copy and paste below 'current configuration'):
//////////////////////////////////////////////////////////////////////////

!--------------------------------------------------------------------------
!
!  For general use on screens from 17 to 22" at >=1280x1024 resolution
!
!----------------------------------____------------------------------------
 Width of ASCP  window in pixels:  1120
Height of ASCP  window in pixels:   660                    <--- for double ht
                    Name of font:  Courier New
         Extended font attribute:     1
         Extended font attribute:     5
         Extended font attribute:     9
         Extended font attribute:    12
!----------------------------------____------------------------------------

!--------------------------------------------------------------------------
!
!  Optimum for 22" screens
!
!----------------------------------____------------------------------------
 Width of ASCP  window in pixels:  1280
Height of ASCP  window in pixels:   660                    <--- for double ht
                    Name of font:  Courier New
         Extended font attribute:     1
         Extended font attribute:     5
         Extended font attribute:     9
         Extended font attribute:    12
!----------------------------------____------------------------------------

!--------------------------------------------------------------------------
!
!  For laptop use with vertical taksbar
!
!----------------------------------____------------------------------------
 Width of ASCP  window in pixels:   960
Height of ASCP  window in pixels:   540
                    Name of font:  Courier New
         Extended font attribute:     1
         Extended font attribute:     5
         Extended font attribute:     9
         Extended font attribute:    12
!----------------------------------____------------------------------------

!--------------------------------------------------------------------------
!
!  For use with standar projector (1024x768) from a laptop with
!  taskbar at the bottom (minimal LW screen cutoff)
!
!----------------------------------____------------------------------------
 Width of ASCP  window in pixels:   880
Height of ASCP  window in pixels:   510
                    Name of font:  Courier New
         Extended font attribute:     3
         Extended font attribute:     5
         Extended font attribute:     9
         Extended font attribute:    12
!----------------------------------____------------------------------------


SVIEW_L.INP configuration file

The SVIEW_L.INP configuration file:
The presence of this file determines whether ASCP_L and SVIEW_L are to operate in linked mode as part of the AABS package.

The example SVIEW_L.INP file below begins with the first line beginning with the ! character. This character defines that the pertinent line is a comment line and the number of such lines is unlimited. Only the five lines following the comments are read.

!-------------------------------------------------------------------------!
!                                                                         !
!   This is a control file for linked operation of ASCP and SVIEW         !
!                                                                         !
!--------------------------------------------------------------------------
!
!   The fitting data file can be:
!          1/ either a .LIN file for PICKETT's SPFIT program
!          2/ or an .ASF file for ASFIT
!
!   Frequency of BEEP signal is in Hz, duration is in milliseconds.
!
!   Peakfinder file is to be generated by the SVIEW_L peakfinder.
!
!   Please modify only the entries starting from the column indicated
!   below.
!_______________________________________
!                                       |
            Name of fitting data file:  2a.asf
Nominal error of measured frequencies:  0.05
     Frequency,duration of F1,F2 beep:  3000,80
    Peakfinder output for Loomis-Wood:  ether.fre
Gle version: <=4.0.7 (=0), >=4.1 (=1):  1
!--------------------------------------------------------------------------

It is hoped that this file is self-documenting, but here are some additional notes concerning the various options:
  • Fitting file: Declaration of a bona-fide fitting data file is compulsory, and its extension is used to determine the fitting program to be used. Currently the only two possibilities for extensions are .asf and .lin for the use of ASFIT or SPFIT, respectively.
  • Nominal error: this is added to the measurement entry appended to the fitting file. The value should be declared in the convention used by SPFIT, in which a positive value of the error implies that the frequency is in MHz, and a negative value of the error implies frequency in cm-1.
  • Peakfinder file: this is only required when an attempt to launch the Loomis-Wood mode is made. This file is to be generated with SVIEW_L
  • Gle version: this declaration of the version of the gle package is also optional. If it is not made then the use of gle4.0.7 or earlier is assumed. The use of gle4.1 or of a more recent version allows immediate preview of output in the qgle viewer and WYSIWYG annotations on the diagram. The two options only differ in some script lines, which ensure identical appearance of the diagram irrespective of the version of gle.


MOLNAM.INP batch input file for ASCP_L

The MOLNAM.INP batch input file for ASCP_L:
This file is used by ASCP_L to load multiple data files, and is useful in both stand alone mode and for AABS operation. The data files can be any mixture of legal input types, but when mixing .ASR and .CAT files remember that their intensities differ by a factor of 4.8 (see the Crib-sheet to SPFIT/SPCAT).

The input can be filtered in frequency and in intensity (if desired) and an echo file of such filtered input can also be generated and is written to file echo.asc.

The MOLNAM.INP file can begin with any number of comment lines identified by the exclamation character (!) in the first column. These lines are ignored on input and are optional. The first actual command is the line defining the filtering parameter. The first 28 characters of each command line are comments, and are ignored. Reedited values should all begin on the 29'th column, as is the case below. Note the use of a custom colour for the 2a.asr dataset defined by means of its hexadecimal RGB code.

The first data set is treated differently from the others since it is assigned the default linestyle 1 and relative intensity of 1. The remaining data files have declarable line style parameters and relative intensities. The linestyle codes are defined separately . The input blocks for each file have to be separated by a compulsory separation line. The complete example file is reproduced below, and some variants of this scheme are also discussed further below.

!--------------------------------------------------------
! Sample batch input file for ASCP_L
!--------------------------------------------------------
!
         filtering (1/0):   1
        frequency limits:   105000.0,367000.0
        intensity cutoff:   1.E-9
         echo file (1/0):   0
------------------------------------------------
       parent data file :   tt.ASR
more data (1), end (0)  :   1
------------------------------------------------
name of data file       :   tg.asr
intensity rel. to parent:   0.45
line code (1-10)        :   8
more data (1), end (0)  :   1
------------------------------------------------
name of data file       :   v20v39.cat
intensity rel. to parent:   0.4
line code (1-10)        :   9
more data (1), end (0)  :   1
------------------------------------------------
name of data file       :   b.asr
intensity rel. to parent:   0.38
line code (1-10)        :   4
more data (1), end (0)  :   1
------------------------------------------------
name of data file       :   d.asr
intensity rel. to parent:   0.25
line code (1-10)        :   6
more data (1), end (0)  :   1
------------------------------------------------
name of data file       :   2a.asr
intensity rel. to parent:   0.25
line code (1-10)        :   11,#FFAA55  = orange
more data (1), end (0)  :   1
------------------------------------------------
name of data file       :   so2.cat
intensity rel. to parent:   1.5
line code (1-10)        :   7
more data (1), end (0)  :   1
------------------------------------------------
name of data file       :   so2_v2.cat
intensity rel. to parent:   1.
line code (1-10)        :   7
more data (1), end (0)  :   1
------------------------------------------------
name of data file       :   so2_34.cat
intensity rel. to parent:   0.0633
line code (1-10)        :   7
more data (1), end (0)  :   1
------------------------------------------------
name of data file       :   so2_33.cat
intensity rel. to parent:   0.0114
line code (1-10)        :   7
more data (1), end (0)  :   1
------------------------------------------------
name of data file       :   so2_18.cat
intensity rel. to parent:   0.00612
line code (1-10)        :   7
more data (1), end (0)  :   0
------------------------------------------------

Several variants of the main structure are possible. The first allows declaration of custom colours. In this case the linestyle parameter is to be assigned the next unused colour index above 10 and is to be followed by the hexadecimal colour code in the form #RRGGBB. The text past the code is not read so that it can be used for commenting, as in the example below:
------------------------------------------------
name of data file       :   2a.asr
intensity rel. to parent:   0.25
line code (1-10)        :   11,#FFAA55  = orange
more data (1), end (0)  :   1
------------------------------------------------
It is possible to modify the default relative intensity of 1.0 for the first data set. In order to do this it is necessary to set the 'more data' flag to -1 and to follow its line with an additional line carrying the desired value of the intensity multiplier that is to be applied to the input intensities:

------------------------------------------------
       parent data file :   tt.ASR
more data (1), end (0)  :   -1
intensity multiplier:       10.5
------------------------------------------------
Another possibility is to modify the default colour (1 = yellow) for the first data set. This is declared by setting the 'more data' flag to -2 and following this line with an additional line carrying the desired value of the colour:

------------------------------------------------
       parent data file :   tt.ASR
more data (1), end (0)  :   -2
line code (1-10 or >10) :   2
------------------------------------------------
Note that only one of the two options above can be used, not both simultaneously.

 It is possible for ASCP_L to display squared intensities rather than standard intensities. This might improve comparison with FFT derived spectra displayed in power rather than amplitude mode. This mode is obtained by means of the filtering option:
         filtering (1/0):   2
Additional comments can be placed on any of the command parameter lines, providing that those are separated from the values of the command parameters by several spaces.


LIST file

The LIST file:
This is an optional file for ASCP_L, which is used to identify frequency regions of available data and names of data sources. The file is mostly used for segmented spectra, which have been concatenated from sparsely distributed spectra using the & option of SVIEW_L.

ASCP_L marks frequency regions declared in the LIST file with a red horizontal bar on the marker scale. It is then also possible to jump between neighbouring regions of this type with Ctrl ← and Ctrl → commands.

The file begins with the first line containing the spectral file name. ASCP_L only reads the spectral file name and the frequency limits from each line. Empty lines are ignored on input. The LIST file can be reedited, providing column discipline is preserved. The spectral file name can be replaced by any 12 character alphanumeric.

 CD2I2.069        167294.000 -- 167600.000 MHz,   7651 points @  .04 MHz/pt
 CD2I2.059        167800.000 -- 168155.000 MHz,   8876 points @  .04 MHz/pt
 CD2I2.060        168155.000 -- 168450.000 MHz,   7376 points @  .04 MHz/pt
 CD2I2.061        168450.000 -- 168750.000 MHz,   7501 points @  .04 MHz/pt
 CD2I2.063        168745.000 -- 169100.000 MHz,   8876 points @  .04 MHz/pt
 CD2I2.064        169100.000 -- 169450.000 MHz,   8751 points @  .04 MHz/pt
 CD2I2.062        169410.000 -- 169420.000 MHz,    251 points @  .04 MHz/pt
 CD2I2.065        169445.000 -- 169900.000 MHz,  11376 points @  .04 MHz/pt
 CD2I2.066        169900.000 -- 170250.000 MHz,   8751 points @  .04 MHz/pt
 CD2I2.067        170600.000 -- 170650.000 MHz,   1251 points @  .04 MHz/pt

 CD2I2.068        170600.000 -- 170910.000 MHz,   7751 points @  .04 MHz/pt
 CD2I2.041        184800.000 -- 185000.000 MHz,   5001 points @  .04 MHz/pt
 CD2I2.042        185000.000 -- 185300.000 MHz,   7501 points @  .04 MHz/pt
 CD2I2.043        185300.000 -- 185600.000 MHz,   7501 points @  .04 MHz/pt
 CD2I2.044        185600.000 -- 185900.000 MHz,   7501 points @  .04 MHz/pt
 CD2I2.045        185900.000 -- 186200.000 MHz,   7501 points @  .04 MHz/pt
 CD2I2.046        186028.000 -- 186035.000 MHz,    176 points @  .04 MHz/pt
 CD2I2.047        186101.000 -- 186107.000 MHz,    151 points @  .04 MHz/pt
 CD2I2.048        186200.000 -- 186500.000 MHz,   7501 points @  .04 MHz/pt
 CD2I2.049        186490.000 -- 186800.000 MHz,   7751 points @  .04 MHz/pt

 CD2I2.050        186800.000 -- 187150.000 MHz,   8751 points @  .04 MHz/pt
 CD2I2.051        187150.000 -- 187500.000 MHz,   8751 points @  .04 MHz/pt
 CD2I2.052        187290.000 -- 187295.000 MHz,    126 points @  .04 MHz/pt
 CD2I2.053        187500.000 -- 187850.000 MHz,   8751 points @  .04 MHz/pt


AABS issues

The beeps:

The two main AABS programs make various beeping noises of confirmation/warning using the PC-Speaker channel. Support of this channel seems to vary these days. On desktops it is not too rare to find no device connected to the separate PC-Speaker output on the mainboard, because computer case manufacturers no longer put such a device in the case. The seller, when requested, will attach a small beeper to that connector.

On laptops this channel may be just another channel in the sound card, but often without active volume control. In such case the volume of the beeping sound may be controlled using the beep settings in SVIEW_L.INP. If the sound is too loud simply decrease the duration parameter. This file is reread by pressing the ESC key in either program and the effect tested immediately (say with the minus key in ASCP_L),

It is also possible that the PC-Speaker channel is inactive/muted and may have to be activated in your Windows.
Keyboard input problems:

The keys for using SVIEW_L and ASCP_L are arranged in a pattern that allows convenient operation of the programs with fingers from both hands. The physical layout of these keys, as shown in the two keyboard charts: SVIEW_L_KEYS.PDF and ASCP_L_KEYS.PDF, assumes selection of the EN keyboard for both programs. Many national keyboards will not have the same convenient layout of the keys used for the zooming operations.

There are several known, and fortunately rather rare, issues with the keyboard. The first are keyboard locks arising for two different reasons:

  • A byproduct of rapid use of the various control keys is that the user can inadvertently press the Ctrl S key combination, which stops the program and it no longer responds. If this happens press Ctrl Q. Pressing the ESC key to activate the refresh operation also eliminates the lock.
  • A second type of keyboard lock is when some key combination is pressed that is interpreted as a control sequence not used by the given AABS program, but built into one of the libraries included with it on compilation. In such case the rescue action is also to press the ESC key.
  • There is a not entirely understood behaviour after the F10 key is pressed in ASCP_L: there seems to be some perturbation to the focus on the ASCP_L program window as after pressing F10 the arrow keys (or other special keys) are ignored, while a normal key, such as K or L results in a warning beep on the first press and is only acted upon on the second press. But it is also enough to move to some other opened application window and return for all keys to work normally.

A different type of problem may arise in SVIEW_L on multiple rapid switching between open program windows. It may then become necessary to press a given key twice (or more) in order to execute some commands. This is associated with the way the keyboard in SVIEW_L is sensed so as not to hog system time while waiting for input. The condition is not easy to reproduce so an effective programmed solution is not yet offered. Nevertheless, there is a way to terminate unwanted threads that steal keyboard input:

  • press the F key when in main display of SVIEW_L (as an example of a function that has become problematic)
  • press and hold down the ALT key
  • type 0199 from the numeric keypad
  • release the ALT key
  • press ENTER as many times as necessary to exit the F function

when you should find that the extra keypress has been eliminated. If this doesn't work for you then you can try the ESC operation. If nothing works then the program may have to be closed and restarted.